[aspectc-user] Re: Aspect and GCC 3.4.1

jorgefm at cirsa.com jorgefm at cirsa.com
Wed Nov 17 14:45:26 CET 2004

>I am able to reproduce these error messages with the woven ac++/Puma 0.9
>sources and g++ 3.4.1 on SUSE linux. The same code compiles with g++
>3.3.3. It looks as if the code, which ac++ generates, is not compatible
>with g++ 3.4.1. We will definitely fix this problem, because g++ 3.4.x
>will soon become widely used. However, it will take a few days of work
>and a new ac++ release. The only thing you can do now is to install g++
>3.3 on your machine. If it helps, I could also send you the compiled
>Puma library from my machine.

Thank you Olaf for your quick answer!

I'll be waiting for a new release (the 0.9.1?) because i have
to upgrade some workstations to Mandrake 10.1 and i'm interested
no installing different compilers to avoid future mesh !

Is it possible to add these libs in the static releases? Only for
the latest compilers... like ac++, ag++ binaries.

Thanks again.


More information about the aspectc-user mailing list