[aspectc-user] Error After Running Make on Ubuntu 18.04

Olaf Spinczyk os at aspectc.org
Sat Aug 17 13:46:58 CEST 2019

Hello Gilbert,

yes, this is a known problem, which came up with newer g++ versions.

You have installed g++-5, but have you actually used it? Your parser.cfg
indicated that you still use version 7.4. Please try ...

ag++ --c_compiler g++-5 ...

when compiling *.cc files directly or use ...

export ACFLAGS="--c_compiler g++-5 -k -v1"

for building the examples as described in README. I hope this helps for now.

Best regards,


Am 16.08.19 um 22:35 schrieb Gilbert Pajela:
> Hello,
> I am new to this list, and I am trying to test AspectC++. I downloaded
> the current version 2.2 Linux/x86_64 tarball from
> http://www.aspectc.org/. After running "make" as described in the
> README, I got the following:
> make -C examples/profiling
> make[1]: Entering directory
> '/data/loewenheim/a/gpajela/Downloads/aspectc++/examples/profiling'​
> Compiling main.cc​
> In file included from <ac>:4:​
> In file included from ./genericprofiler.ah:4:​
> In file included from /usr/include/c++/5/iostream:39:​
> In file included from /usr/include/c++/5/ostream:38:​
> In file included from /usr/include/c++/5/ios:38:​
> In file included from /usr/include/c++/5/iosfwd:40:​
> In file included from /usr/include/c++/5/bits/postypes.h:40:​
> In file included from /usr/include/c++/5/cwchar:44:​
> In file included from /usr/include/wchar.h:30:​
> /usr/include/x86_64-linux-gnu/bits/floatn.h:75:52: error: unsupported
> machine mode '__TC__'​
> typedef _Complex float __cfloat128 __attribute__ ((__mode__ (__TC__)));​
>                                                    ^​
> error: Execution failed:
> "/data/loewenheim/a/gpajela/Downloads/aspectc++/ac++" --system-config
> "/tmp/agxx_pcfg5wOGZn"  -p. -c "main.cc" -o "/tmp/main.cc_agxx_H73ui3"​
> ../Makefile.generic:28: recipe for target 'Junk/main.o' failed​
> make[1]: *** [Junk/main.o] Error 1​
> make[1]: Leaving directory
> '/data/loewenheim/a/gpajela/Downloads/aspectc++/examples/profiling'​
> Makefile:18: recipe for target 'profiling.make' failed​
> make: *** [profiling.make] Error 2​
>> My OS is Ubuntu 18.04.3 LTS. However, I tried the same thing on Ubuntu
> 16.04 in a virtual machine, and I did not get this error. Everything was
> fine. Could something possibly have changed in Ubuntu 18.04 that causes
> issues with AspectC++?
> In Ubuntu 18.04, I have g++ version 7.4.0 installed. I wondered what
> would happen if I installed an older version of g++, so I installed
> g++-5 (sudo apt install g++-5) and tried the same thing, but I still got
> an error. I saw a related message previously posted on this list, and it
> said to execute ag++ --gen_config -o parser.cfg. I tried that, and here
> is the end of the generated file parser.cfg:
> --target x86_64-linux-gnu
> --gnu 7.4.0​
> --isystem "/usr/include/c++/7"​
> --isystem "/usr/include/x86_64-linux-gnu/c++/7"​
> --isystem "/usr/include/c++/7/backward"​
> --isystem "/usr/lib/gcc/x86_64-linux-gnu/7/include"​
> --isystem "/usr/local/include"​
> --isystem "/usr/lib/gcc/x86_64-linux-gnu/7/include-fixed"​
> --isystem "/usr/include/x86_64-linux-gnu"​
> --isystem "/usr/include"​
> As far as I know, those paths listed are correct. Is there anything else
> I can do to get this to work under Ubuntu 18.04? I would prefer not to
> have to run AspectC++ from a virtual machine. If you need any additional
> details, please let me know. Any help would be greatly appreciated.
> Thanks,
> Gilbert Pajela
> _______________________________________________
> aspectc-user mailing list
> aspectc-user at aspectc.org
> http://www.aspectc.org/mailman/listinfo/aspectc-user

More information about the aspectc-user mailing list