[aspectc-user] compilation problem: invalid member declaration near token`restrict'

Olaf Spinczyk Olaf.Spinczyk at informatik.uni-erlangen.de
Thu Dec 16 15:13:16 CET 2004

Hi Dmitri,

Dmitri Chelenine wrote:
> Hi!
> I'm trying to compile the puma with vc71 under windows, and getting the 
> following weaving stopper:
> d:/piant/extlib/puma/gen/step1/inc/Puma/CTypeQualified.h:33: error: 
> invalid member declaration near token `restrict'
> d:/piant/extlib/puma/gen/step1/inc/Puma/CTypeQualified.h:52: error: 
> invalid declaration near token `:'
> For all .cc files in gen/step1/src folder
> I don't get it because the CTypeQualified.h has the following declaration:
> 30: class CTypeQualified : public CTypeInfo {
> 31:     bool _Const;
> 32:     bool _Volatile;
> 33:     bool _Restrict;
> 34:
> 35: protected:
> 36:    CTypeQualified (CTypeInfo *, bool, bool, bool, TypeId );
> (... the rest skipped...)
> There isn't even a `restrict' but `_Restrict'!
> Could anybody help me out here?
> Thank you in advance,
> Dmitri.

sorry for the late answer.

We usually cross-compile the ac++ windows version on linux with mingw 
(g++). Therefore, I can't give you very helpful comments here. However, 
some time ago I compiled the woven (!) Puma code in Visual Studio 2003. 
There  were a few problems with the source, which I fixed. I didn't have 
any problems with "_Restrict". Sooner or later we will support Visual 
Studio as a build platform.

I don't know how your make process looks like, but I would recommend to 
use the woven source from Puma/include/Puma (headers) and 
Puma/gen/step2/src (sources). It seems that you tried to compile a 
header file from step1. We have never tried to weave Puma on windows.


More information about the aspectc-user mailing list