Fwd: [aspectc-user] How can I install AC++ on my computer?

刘果 joseph04912654 at gmail.com
Wed Mar 12 05:27:16 CET 2014

I re-install it , and
hello.h:4: error: no include path in which to find `iostream'
world.ah:4: error: no include path in which to find `iostream'
error: Execution failed: "ac++" --config "/tmp/agxx_pcfgmyYwVs"  -p. -c
"main.cc" -o "/tmp/main.cc_agxx_UuXA5Z"
came out when i run "ag++ -o main main.cc". And with "ag++ -o main main.cc
--c_compiler /usr/bin/g++ --ac_compiler /usr/bin/ac++" , I got the same

With use "ag++ -v 9 -o main main.cc" command , I got:
* AG++ Configuration:
*   Aspect C++ weaver:  ac++
*   C++ compiler:       g++
*   Files:               main.cc
*   Options (G++):       -v -o "main"  -I "."
*   Options (AC++):      -v9 -p.
*   Options (total):     -v9 -v -o "main"  main.cc -I "."  -p.
*   PumaConfig: 1 Weave: 1 Compile: 1 Link: 1
* Generating Puma configuration file
  - Parsing output of g++ compiler
  - Executing: "g++"  -E -dM -v -x c++ "/dev/null" 2>/tmp/agxx_stderr4eOGnr
  - Exit: Success
  - removing temporary file: /tmp/agxx_stdoutDA9RS3
  - removing temporary file: /tmp/agxx_stderr4eOGnr
  - Writing puma configuration file '/tmp/agxx_pcfgeHD3nG'
* Weaving
  - Executing: "ac++" --config "/tmp/agxx_pcfgeHD3nG"  -v9 -p. -c "main.cc"
-o "/tmp/main.cc_agxx_dH44TO"
* Running ac++ 1.1
* Handling Translation Unit `main.cc'.
  - Path "main.cc"
  - Inserting namespace AC
  - Parsing ...
hello.h:4: error: no include path in which to find `iostream'
world.ah:4: error: no include path in which to find `iostream'
  - Aborting
error: Execution failed: "ac++" --config "/tmp/agxx_pcfgeHD3nG"  -v9 -p. -c
"main.cc" -o "/tmp/main.cc_agxx_dH44TO"
  - Exitcode: 256 (should be 0 )

I think it just as same as first message , so I really do not know what to
do now.  ;(

---------- Forwarded message ----------
From: Julian Rost <julian at rost.biz>
Date: 2014-03-11 22:44 GMT+08:00
Subject: Re: [aspectc-user] How can I install AC++ on my computer?
To: 刘果 <joseph04912654 at gmail.com>


could you just try to install it with "sudo apt-get install aspectc++" from
the commandline and look what happens now? Else try to use the --c_compiler
`path to g++` and --ac_compiler `path to ac++` options at your ag++ call.
If further problems exist, try to use -v 9 to analyse your problems.

Many greetings

Am 2014-03-11 14:56, schrieb 刘果:

> Hello ,
>        I am a student of software engineering in China, and my
> teacher asked us to do something with aspectc++. I am using UBUNTU
> 12.04 , so , I went to http://www.aspectc.org/ [1] and got the latest
> version(1.2  Linux/x86).  Then got the "aspectc++" directory. But when
> I run "make" command in the directory, I got "no include path path in
> which to find `iostream` " message. Also , I have tried to install it
> by "sudo apt-get install apsectec++ " command, and run "ag++ -o main
> main.cpp" (main.cpp is in aspectc++/examples/helloworld directory) ,
> get the same message again, also with "ag++ -o main main.cpp --include
> `iostream path` "! Could somebody tell me how can i fix it ?  Thanks a
> lot.
> Links:
> ------
> [1] http://www.aspectc.org/
> _______________________________________________
> aspectc-user mailing list
> aspectc-user at aspectc.org
> http://www.aspectc.org/mailman/listinfo/aspectc-user
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.aspectc.org/pipermail/aspectc-user/attachments/20140312/89342808/attachment.html>

More information about the aspectc-user mailing list