[aspectc-user] compile error when using puma

Ralf Stephan ralf at ark.in-berlin.de
Mon Dec 5 17:57:06 CET 2005

> this problem is a problem of the build environment. The Puma header 
> files are the result of a weaving process. Depending on your TARGET 
> setting, i.e. debug or release mode, while compiling, the resulting 
> header files are different. By default, Puma is compiled with the 
> TARGET setting "linux-release". In the file Puma/vars.mk you can 
> see that in this case -DNDEBUG is used as a compiler option. I 
> suppose that this option is missing in your command line.

Right, many thanks, it compiles and nearly works now. But
first I note that compiling Puma with -g in the CFLAGS gives
a segfault here when compiling PreFileIncluder.cc. I can work
around it by only later giving the -g option.

After fixing several other problems in my program, I then came to
the point where the match string was worked on and nearly all
wildcards were wrong because the names changed in the meantime. 
Although I found Puma/scanner/CWildcardTab.ora, no match was
possible, even not the single keyword 'class'. Could you
please give me a match string that matches any declaration of
class X, for example?

thanks, regards

More information about the aspectc-user mailing list